From: Thorsten Ottosen (nesotto_at_[hidden])
Date: 2004-08-12 06:08:13
Finally I have written the documentation for boost.range.
Everyone who is interested should take a look at it all in the cvs and let me know what you think.
(If you don't have cvs access, just mail me so I can send it)
There is one major decisions that I think should be decided upon in this post-review, ans it is about naming.
The boost iterators new iterator traits has this naming scheme:
I have used this scheme (originally proposed by Peter Dimov)
The question is now if the range librray should do as the iterator library, ie, prefix everyhitng with "range_":
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk