From: David Abrahams (dave_at_[hidden])
Date: 2004-08-12 07:36:20
"Thorsten Ottosen" <nesotto_at_[hidden]> writes:
> Dear All,
> Finally I have written the documentation for boost.range.
> Everyone who is interested should take a look at it all in the cvs and
> let me know what you think.
> (If you don't have cvs access, just mail me so I can send it)
> There is one major decisions that I think should be decided upon in
> this post-review, ans it is about naming.
> The boost iterators new iterator traits has this naming scheme:
> I have used this scheme (originally proposed by Peter Dimov)
> The question is now if the range librray should do as the iterator
> library, ie, prefix everyhitng with "range_":
We chose "iterator_value" et al because we couldn't be sure that
someone wouldn't need to make another concept Q in boost that had its
own, separate notion of an value_type. If you then had a type X that
fulfilled both the Iterator and Q concepts, how would you specialize
I would be happy to unify these using Peter's names if we could give
the problem above some thought and resolve it (even if that means
deciding "it's not a problem").
-- Dave Abrahams Boost Consulting http://www.boost-consulting.com
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk