Boost logo

Boost :

From: David Abrahams (dave_at_[hidden])
Date: 2004-08-13 12:01:13

Daniel Frey <daniel.frey_at_[hidden]> writes:

> Hartmut Kaiser wrote:
>> Thorsten Ottosen wrote:
>>> typename boost::range::value<T>::type
>>> typename boost::range_value<T>::type
>>> I think my personal view would be that I think range_ reads better
>>> than range::. Too many :: and it seems a bit confusing.
>> I'm personally prefer to use namespaces to structurize the code,
>> i.e. the typename range::value<T>::type
>> notation. The range_value<T>::type notation unneededly clutters the
>> global'
>> boost namespace.
> I agree. Also, the user can use namespace aliases to shorten calls,
> which doesn't work with range_.
> The difference for the user is also quite minimal, but using
> namespaces might also help to keep the library "cleaner" internally,
> as the algorithms in range:: can call each other without long names.

Are we sure we want boost::range to be a namespace and not a class or
a template, forever?

I had a horrible thought: boost::range_traits::value<R>::type

Dave Abrahams
Boost Consulting

Boost list run by bdawes at, gregod at, cpdaniel at, john at