|
Boost : |
From: Daniel Frey (daniel.frey_at_[hidden])
Date: 2004-08-13 04:40:39
Hartmut Kaiser wrote:
>
> Thorsten Ottosen wrote:
>>
>>typename boost::range::value<T>::type
>>
>>typename boost::range_value<T>::type
>>
>>I think my personal view would be that I think range_ reads
>>better than range::. Too many :: and it seems a bit confusing.
>
> I'm personally prefer to use namespaces to structurize the code, i.e. the
>
> typename range::value<T>::type
>
> notation. The range_value<T>::type notation unneededly clutters the 'global'
> boost namespace.
I agree. Also, the user can use namespace aliases to shorten calls,
which doesn't work with range_.
The difference for the user is also quite minimal, but using namespaces
might also help to keep the library "cleaner" internally, as the
algorithms in range:: can call each other without long names.
Regards, Daniel
-- Daniel Frey aixigo AG - financial solutions & technology Schloß-Rahe-Straße 15, 52072 Aachen, Germany fon: +49 (0)241 936737-42, fax: +49 (0)241 936737-99 eMail: daniel.frey_at_[hidden], web: http://www.aixigo.de
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk