Boost logo

Boost :

From: Thorsten Ottosen (nesotto_at_[hidden])
Date: 2004-08-14 05:30:25

"Rob Stewart" <stewart_at_[hidden]> wrote in message
| From: David Abrahams <dave_at_[hidden]>
| > "Thorsten Ottosen" <nesotto_at_[hidden]> writes:
| >
| > > The primary motivation for the namespace version seems to be
| > > shortening of names.
| >
| > That doesn't seem very compelling to me.
| I thought it was to bring consistency to the template names
| across the various namespaces. Remember value, iterator,
| const_iterator, difference, size, etc. from Thorsten's list? The
| same names could be used in different namespaces for the same
| purpose. Whether such names were qualified, and whether the
| qualification was shortened in any way, was up to the context
| and user.

I'm feeling less and less comfortable with the namespace version. Shorter names don't seem to be an issue.
Namespaces on concepts seems to be an issue. We cannot use the same namespace for size as a function and metafuntion
nor bring them into the same scope.

The smallest change is not to change the iterator library and therefore I will
use the prefix range_ for my metafunctions unless there are heavy objections.



Boost list run by bdawes at, gregod at, cpdaniel at, john at