Boost logo

Boost :

From: Jonathan Wakely (cow_at_[hidden])
Date: 2004-09-03 05:10:50

On Fri, Sep 03, 2004 at 10:16:39AM +0200, Thorsten Ottosen wrote:

> Dear all,
> John Torjo asks why don't rename the Range concepts empty() function to the more idiomatic and less embarrassing
> name is_empty()?
> My initial thoughts were if this could ceate more confusion, but I'm beginning to think John is right.
> So if people would cast some yes or no votes it would be great.

Hmm ... the function takes its argument by const-reference, so it's
"obvious" it doesn't empty the range if you've seen the function
declaration. (But anything "obvious" will fail to be obvious to
some people).

Although it would be nice if the STL had used is_empty() it's too late
to change that now, and Boost's web site does say:

  The emphasis is on libraries which work well with the C++ Standard

I think consistency with the existing name is important.


"The tools we use have a profound (and devious!) influence on our
 thinking habits, and, therefore, on our thinking abilities."
	- Edsger Dijkstra

Boost list run by bdawes at, gregod at, cpdaniel at, john at