Boost logo

Boost :

From: Rob Stewart (stewart_at_[hidden])
Date: 2004-09-03 16:15:31

From: "Thorsten Ottosen" <nesotto_at_[hidden]>
> John Torjo asks why don't rename the Range concepts empty()
> function to the more idiomatic and less embarrassing name
> is_empty()?
> My initial thoughts were if this could ceate more confusion,
> but I'm beginning to think John is right.
> So if people would cast some yes or no votes it would be great.

I think is_empty() is better. As a mf, empty() is a poor name.
As a non-member function, it is worse. Why perpetuate a bad
thing just for consistency?

"A foolish consistency is the hobgoblin of little minds," said
Ralph Waldo Emerson.

Rob Stewart                           stewart_at_[hidden]
Software Engineer           
Susquehanna International Group, LLP  using std::disclaimer;

Boost list run by bdawes at, gregod at, cpdaniel at, john at