From: Thorsten Ottosen (nesotto_at_[hidden])
Date: 2004-09-15 12:33:32
"Jeff Flinn" <TriumphSprint2000_at_[hidden]> wrote in message
| "David Abrahams" <dave_at_[hidden]> wrote in message
| > "Thorsten Ottosen" <nesotto_at_[hidden]> writes:
| > I wonder whether it's better to say
| > cbegin(x)
| > or
| > begin(as_const(x))
| > The latter is certainly more general.
| Does this imply that the following would be possible:
| begin( as_reverse(x) )
rbegin(x) is alreeady there as a parallel to x.rbegin().
| begin( as_const( as_reverse(x) ) )
| begin( as_reverse( as_const(x) ) )
yes, I think so with some metaprgramming, but its getting quite hard to read
compared to the single version.