Boost logo

Boost :

From: Rob Stewart (stewart_at_[hidden])
Date: 2004-09-15 15:06:11

From: "Thorsten Ottosen" <nesotto_at_[hidden]>
> "Jeff Flinn" <TriumphSprint2000_at_[hidden]> wrote in message
> | begin( as_const( as_reverse(x) ) )
> | begin( as_reverse( as_const(x) ) )
> yes, I think so with some metaprgramming, but its getting quite hard to read
> compared to the single version.

Those are getting harder to read, but they do offer complete
generality. Composing those is straightforward, whereas you
could forget the correct order if there was only
as_const_reverse(), for example.

Rob Stewart                           stewart_at_[hidden]
Software Engineer           
Susquehanna International Group, LLP  using std::disclaimer;

Boost list run by bdawes at, gregod at, cpdaniel at, john at