Boost logo

Boost :

From: Rob Stewart (stewart_at_[hidden])
Date: 2004-09-21 13:57:03

From: "Reece Dunn" <msclrhd_at_[hidden]>
> John Torjo wrote:
> >>>>2. If primary target is collection formatting wouldn't it be better to
> >>>>name library "collection formats something"?
> >>>
> >>>This is a good idea. The name is from when the library just had output
> >>>support, thus the "outfmt" directory in the sandbox. I am thinking about
> >>>moving to a "formatter" directory. What do other people think?
> >>
> >>
> >>I'm -1. Having "format" and "formatter" is confusing. The name should
> >>somehow mention that you format data structures.
> >
> >I second that - 'formatter' is just confusing.
> >However, something like 'coll_format' or 'sequence_format' - I'm ok with
> >them.

"sequence_format" suggests it won't work with associative
containers, for example.

> 'coll_format' has got my vote :)

"coll" suggests "collate" just as easily as "collection" and
"collate" seems the more likely inference since "coll" is
followed by "format." (That's what I thought of when I saw
"coll_format" anyway.) If it was "collection_format" it could

Rob Stewart                           stewart_at_[hidden]
Software Engineer           
Susquehanna International Group, LLP  using std::disclaimer;

Boost list run by bdawes at, gregod at, cpdaniel at, john at