Boost logo

Boost :

From: Richard Smith (richard_at_[hidden])
Date: 2004-10-14 10:36:49

Is there any chance that the virtual function
boost::detail::is_polymorphic_imp1<T>::d2::foo defined in
boost/type_traits/is_polymorphic.hpp could be renamed to
have a name less likely to cause conflicts?

I appreciate that the unique struct prevents this function
from overriding any virtual functions in the base class, but
it still has the potential to hide base class functions,
which, at suitable warning levels in many compilers, causes
a lengthy warning to be emitted.

Although foo is unlikely to be a common function name in
production code (well, good production code, anyway), it is
the sort of name that is frequently found within unit tests
and so forth. (For example, the name ``foo'' is used 2657
times in the gcc testsuite.)

Richard Smith

Boost list run by bdawes at, gregod at, cpdaniel at, john at