Boost logo

Boost :

From: Beman Dawes (bdawes_at_[hidden])
Date: 2004-11-08 11:17:08

At 08:10 AM 11/8/2004, John Torjo wrote:
>>>No comments of the code itself, however I'm not a fan of rng as a
>>>namespace, I keep reading Random Number Generator.
>>>helpfully though I can't think of an alternative!
>>>range (likely to conflict?)
>>>irange (likely to be used as a variable name in place of 'i' ?)
>>>irl (not good either)
>>>rangelib (too long?)
>> Tradition would dictate "ranges"
>I'm fine with ranges:: namespace, although I find it a little big
>(containing too many chars).

But it is way better than "rng", IMO. I'm like John, and read rng as random
number generator.


Boost list run by bdawes at, gregod at, cpdaniel at, john at