From: John Maddock (john_at_[hidden])
Date: 2005-02-04 08:31:59
> With the recent addition of TR1 aligned_storage to
> Boost.TT, there's a nasty collision with a class named
> exactly the same and living in boost/aligned_storage.hpp
> (this class is a spin-off from Boost.Variant, IIRC.)
> I think this has been discussed some months ago, but
> with no resolution to the best of my knowledge.
> Apart from the symbol clash, these two classes do not
> provide the same functionality, so I guess it'd be sensible
> to rename the older aligned_storage to something else.
Darn, normally I'd say that the older version has priority over the name,
however in this case since aligned_storage is part of the TR, I'm leaning
toward agreeing that we should rename the old version.
I notice that the old version isn't documented anywhere, but I also note
from the mailing list that at least one person is using it in his/her own
So I'm not sure how best to handle this, Eric, any thoughts?
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk