Boost logo

Boost :

From: Gennadiy Rozental (gennadiy.rozental_at_[hidden])
Date: 2005-02-07 10:35:12

> I could add a public "reset" member function to do the work of undoing the
> change, and simply have the destructor call that. This allows
> multiple-resets.
> 1. Would "reset" be a good name for this member function?

maybe restore?

> 2. Is it worth it to complicate the current simple-RAII interface
> for 99% of users for the sake of the 'wacky' 1% that actually
> need multi-restore?

It's up to you. I do not know how frequent;y we would need something like


Boost list run by bdawes at, gregod at, cpdaniel at, john at