From: Thorsten Ottosen (nesotto_at_[hidden])
Date: 2005-02-16 09:52:52
"David Abrahams" <dave_at_[hidden]> wrote in message
|I've heard the term "pointainer" somewhere. Not that I like it or
I agree, its not that good.
| I believe "indirect" is superior -- I am assuming containers of
| dereferenceable types other than pointers (like iterators) are also
Curently they are not, unless the iterator happens to be a pointer.
The trouble in that case would be that my implementation used void*
underneith and hence has special iterators that does a reinterpret_cast.
A reinterpret_cast appears here and there in the container's implmentation
So given that iterators in general are not supported, would you then prefer
the ptr_ prefix?