Boost logo

Boost :

From: David Abrahams (dave_at_[hidden])
Date: 2005-02-16 09:38:35

Joaquín Mª López Muñoz <joaquin_at_[hidden]> writes:

> Thorsten Ottosen ha escrito:
>> Dear all,
>> I will soon start to write some more documentation for the
>> indirect container library (formerly called the smart container library).
>> Before I start on that I would like to get a vote on the preferred naming
>> of
>> 1. the library itself
>> 2. library classes
>> Ad 1: library name:
>> --------------------
>> Boost.Indirect Cotainer was suggested by Joaquin. It sounds reasonable to me.
>> I don't have any alternatives, but suggestions are welcome.
> Maybe Boost Pointer Containers would also do, specially if you keep
> the ptr_xxx names.

I've heard the term "pointainer" somewhere. Not that I like it or

I believe "indirect" is superior -- I am assuming containers of
dereferenceable types other than pointers (like iterators) are also

Dave Abrahams
Boost Consulting

Boost list run by bdawes at, gregod at, cpdaniel at, john at