From: Jonathan Turkanis (technews_at_[hidden])
Date: 2005-02-16 19:09:07
Thorsten Ottosen wrote:
> In some sense it seems like we're trying to cram two different
> classes into one. The indirect behavior could be provided by one
> (or three) containers of the form
I'm starting to agree.
> template< class Sequence >
> template< class Set >
> template< class Map >
> This might belong in a different library.
If indirection is not really the unifying theme, perhaps you should use the name
Boost.ManagedContainer, which I think was suggested at some point.
('ManagingContainer' might be more correct, but doesn't sound good.)
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk