Boost logo

Boost :

From: Thorsten Ottosen (nesotto_at_[hidden])
Date: 2005-02-17 14:12:18


| Thorsten Ottosen wrote:
|
| > In some sense it seems like we're trying to cram two different
| > classes into one. The indirect behavior could be provided by one
| > (or three) containers of the form
|
| I'm starting to agree.

thanks. after giving it some thought, then I also agree with myself :-)

| > template< class Sequence >
| > indirect_sequence;
| >
| > template< class Set >
| > indirect_set;
| >
| > template< class Map >
| > indirect_map;
| >
| > This might belong in a different library.
|
| VTL, perhaps.

yeah, something like that.

| If indirection is not really the unifying theme, perhaps you should use the
name
| Boost.ManagedContainer, which I think was suggested at some point.
| ('ManagingContainer' might be more correct, but doesn't sound good.)

Managed container is a good name. To recap, I think these are good condidates:

Boost. Managed Container
Boost. Managed Pointer Container
Boost. Pointer Container
Boost. Clonable Container
Boost. Clonable Pointer Container
Boost. Cloned Container

My personal favourite would be Boost.Cloned Container
with class names like this:

cloned_vector<T>
cloned_map<Key,T>

When I think about it, I see cloning as the most central concept; in fact, the
only new policy of the containers is the CloneAllocator.

-Thorsten


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk