Boost logo

Boost :

From: Jonathan Turkanis (technews_at_[hidden])
Date: 2005-02-17 15:33:40

> ----- Mensaje original -----
> De: Thorsten Ottosen <nesotto_at_[hidden]>
> Fecha: Jueves, Febrero 17, 2005 8:12 pm
> Asunto: [boost] Re: [indirect container] RFC on naming of library
> andclasses
> [...]
>>> If indirection is not really the unifying theme, perhaps you
>> should use the
>> name
>>> Boost.ManagedContainer, which I think was suggested at some point.
>>> ('ManagingContainer' might be more correct, but doesn't sound good.)
>> Managed container is a good name. To recap, I think these are good
>> condidates:
>> Boost. Managed Container
>> Boost. Managed Pointer Container
>> Boost. Pointer Container
>> Boost. Clonable Container
>> Boost. Clonable Pointer Container
>> Boost. Cloned Container

>> My personal favourite would be Boost.Cloned Container
>> with class names like this:
>> cloned_vector<T>
>> cloned_map<Key,T>

I dislike the names involving clonability. Isn't it true that in many ordinary
uses of the library there will be no cloning?

> As for the "managed" line, I think it resonates with some issues
> none of which has to do with the subject at hand:
> * "managed" as bounds checked.
> * "managed" as belonging to the world of C++/CLI (ugh!)

We don't have to avoid every term Microsoft (or some other vendor) has uzed as a
buzzword, do we?

> Joaquín M López Muñoz
> Telefónica, Investigación y Desarrollo


Boost list run by bdawes at, gregod at, cpdaniel at, john at