Boost logo

Boost :

From: Larry Evans (cppljevans_at_[hidden])
Date: 2005-03-02 18:59:43


On 03/02/2005 01:14 PM, Larry Evans wrote:
> Would it be possible to add:
>
> template<typename Application>struct unpack_apply;
> such that:
>
> is_same
> < unpack_apply<f<a0,a2,...,an> >::type
> , vector<a0,a2,...,an>
> >
>
> to mpl? Maybe a better name would be get_args, but
> since it's so closely related to unpack_args

Actually, I think I misunderstood unpack_args. The code
in http://boost-sandbox.sourceforge.net/vault/ in:

   cppljevans/mpl/application_parts_test.cpp

contains boost::mpl::application_parts2 which is what I want.
It just applies to 2 arguments, but I guess it could
be extended for 0..MAXARG arguments using boost/preprocessor.

This could would be useful in classes like get_side_type
(in same vault location) or any meta program which needs
to dissect the parts of a template application.


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk