Boost logo

Boost :

From: David Abrahams (dave_at_[hidden])
Date: 2005-03-24 09:19:47

"Eric Niebler" <eric_at_[hidden]> writes:

> David Abrahams wrote:
>> "Eric Niebler" <eric_at_[hidden]> writes:
>>> But you still haven't given me a reason I can understand why it
>>> shouldn't be "boost_range_begin()" etc..
>> Peter Dimov made some excellent arguments in the thread containing
>> (click the
>> subject line to see the thread).
> It's true he made some excellent arguments in that thread, but this is a
> different argument. ;-) Once you accept as a given that we should be
> using an ADL customization point, what should we call it?

It's not an entirely different argument. Peter was saying that once
you publicize the customization point, it no longer "belongs" to the
library. Imagine what happens if some other library wanted to use the
same range concept, but not depend on Boost itself. Either they'd be
picking a new ugly name for a customization point with identical
semantics :( or they'd be using the name "boost_range_begin" in code
with no Boost relationship in sight :(.

As my wife's co-worker says, "it's a two-headed sword" ;-)

For that reason, it might be better to use something like
"iterator_range_begin" that has a hope of becoming lingua franca like
swap. At least that's how I understand Peter's argument.

Dave Abrahams
Boost Consulting

Boost list run by bdawes at, gregod at, cpdaniel at, john at