Boost logo

Boost :

From: Thorsten Ottosen (nesotto_at_[hidden])
Date: 2005-03-24 11:02:37

"David Abrahams" <dave_at_[hidden]> wrote in message
| "Eric Niebler" <eric_at_[hidden]> writes:

| It's not an entirely different argument. Peter was saying that once
| you publicize the customization point, it no longer "belongs" to the
| library. Imagine what happens if some other library wanted to use the
| same range concept, but not depend on Boost itself. Either they'd be
| picking a new ugly name for a customization point with identical
| semantics :( or they'd be using the name "boost_range_begin" in code
| with no Boost relationship in sight :(.
| As my wife's co-worker says, "it's a two-headed sword" ;-)
| For that reason, it might be better to use something like
| "iterator_range_begin" that has a hope of becoming lingua franca like
| swap. At least that's how I understand Peter's argument.

Hm.. yeah...I guess you're better at expressing my point than
I myself :-)

iterator_range_ seems to be a good prefix.

What do you say, Eric, do you like
iterator_range_begin() etc?


Boost list run by bdawes at, gregod at, cpdaniel at, john at