From: Thorsten Ottosen (nesotto_at_[hidden])
Date: 2005-04-04 13:06:23
"Thomas Witt" <witt_at_[hidden]> wrote in message
| Thorsten Ottosen wrote:
| > Dear all,
| > Have anybody any last objections to breaking changes to boost.range:
| > boost::range_iterator<T>::type
| > becomes
| > boost::range::iterator<T>::type
| > and so forth. All code that relies on
| > ADL inside the range library by overloading the functions begin() etc
| > will need to be renamed range_begin() etc.
| Sorry I was unresponsive for a few days but I was travelling. I still
| think this is the wrong way to do it. One reason is that it requires
| every library X that wants to interface with the range lib to uglify its
| interface by the range_ prefix.
yes, but in return the library only has two provide one overload
|AFAICS there are two ways out of this
| a) X provides the unprefixed begin as well.
how does that solve anything?
| b) X requires the use of boost.range in order to have a "natural" interface
| I really think this is bad.
a) or b) ?
| If we want to have adl wrappers
what is an ADL wrapper?