From: Thomas Witt (witt_at_[hidden])
Date: 2005-04-04 12:24:04
Thorsten Ottosen wrote:
> Dear all,
> Have anybody any last objections to breaking changes to boost.range:
> and so forth. All code that relies on
> ADL inside the range library by overloading the functions begin() etc
> will need to be renamed range_begin() etc.
Sorry I was unresponsive for a few days but I was travelling. I still
think this is the wrong way to do it. One reason is that it requires
every library X that wants to interface with the range lib to uglify its
interface by the range_ prefix. AFAICS there are two ways out of this
a) X provides the unprefixed begin as well.
b) X requires the use of boost.range in order to have a "natural" interface
I really think this is bad. If we want to have adl wrappers these should
carry the prefixes.
What did I miss?
-- Thomas Witt witt_at_[hidden]
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk