Boost logo

Boost :

From: David Abrahams (dave_at_[hidden])
Date: 2005-05-02 19:52:39

What is the rationale behind this name? It seems unintuitive to me,
and what's more, unneccessary. Shouldn't
range_iterator<T const>::type just be range_const_iterator<T>::type?

If not, why not?

Dave Abrahams
Boost Consulting

Boost list run by bdawes at, gregod at, cpdaniel at, john at