From: David Abrahams (dave_at_[hidden])
Date: 2005-05-03 07:22:56
"Thorsten Ottosen" <nesotto_at_[hidden]> writes:
> "David Abrahams" <dave_at_[hidden]> wrote in message
> | I was just looking at using Boost.Range in my new Sequence library and
> | noticed the following:
> | 1. The documentation of requirements uses names like range_iterator
> | without qualification. You need to add the boost:: prefix or
> | make it very clear that all names are implicitly boost:: prefixed
> | (as opposed to, say, boost::range:: prefixed). I prefer the
> | former; people may land on the documentation for reference
> | without reading all the introductory material.
> | 2. Names like range_iterator in the requirements tables should be
> | hyperlinked to some documentation for them.
> yeah, good idea.
> | 3. The documentation you land on should clearly state in which
> | header those names can be found.
> there is a header section.
I know that. But when you land on the documentation for range_value
(for example) the header it's in should be visible.
> | 4. Having a pile of names prefixed by "range_" (like
> | boost::range_const_iterator) just seems wrong to me when we have
> | namespaces. Is there a good reason we're not using
> | boost::range::const_iterator or boost::ranges::const_iterator?
> decision made in review or post-review. people like it that way.
Count one more vote against, FWIW.
-- Dave Abrahams Boost Consulting www.boost-consulting.com
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk