From: Thorsten Ottosen (nesotto_at_[hidden])
Date: 2005-05-03 11:12:39
"David Abrahams" <dave_at_[hidden]> wrote in message
| "Thorsten Ottosen" <nesotto_at_[hidden]> writes:
| > "David Abrahams" <dave_at_[hidden]> wrote in message
| > news:u1x8pceqw.fsf_at_boost-consulting.com...
| > |
| > | What is the rationale behind this name? It seems unintuitive to
| > | me, and what's more, unneccessary.
| > why?
| Unintuitive: it's not clear what The "result" part refers to. It's
| such a generic word when applied to a (meta)function that it lacks
| obvious semantic content... it's almost like naming the max fucntion
well, I think const_if_arg_is_const_mutable_otherwise_iterator<T>::type was
ideas are welcome.
| > | Shouldn't range_iterator<T const>::type just be
| > | range_const_iterator<T>::type?
| > |
| > | If not, why not?
| > container::const_iterator is the parallel.
| That doesn't explain anything (to me). What I was asking was: why
| provide this oddly-named metafunction when people could just make the
| inquiry using range_iterator with a const argument?
I guess the design could havebeen that way; but we don't say container< const
T >::iterator to get container<T>::const_iterator.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk