Boost logo

Boost :

From: David Abrahams (dave_at_[hidden])
Date: 2005-05-03 07:28:44

"Thorsten Ottosen" <nesotto_at_[hidden]> writes:

> "David Abrahams" <dave_at_[hidden]> wrote in message
> |
> | What is the rationale behind this name? It seems unintuitive to
> | me, and what's more, unneccessary.
> why?

Unintuitive: it's not clear what The "result" part refers to. It's
such a generic word when applied to a (meta)function that it lacks
obvious semantic content... it's almost like naming the max fucntion

> | Shouldn't range_iterator<T const>::type just be
> | range_const_iterator<T>::type?
> |
> | If not, why not?
> container::const_iterator is the parallel.

That doesn't explain anything (to me). What I was asking was: why
provide this oddly-named metafunction when people could just make the
inquiry using range_iterator with a const argument?

Dave Abrahams
Boost Consulting

Boost list run by bdawes at, gregod at, cpdaniel at, john at