Boost logo

Boost :

From: Thorsten Ottosen (nesotto_at_[hidden])
Date: 2005-05-03 12:02:22

"Jonathan Turkanis" <technews_at_[hidden]> wrote in message
| Thorsten Ottosen wrote:
| >>> 4. Having a pile of names prefixed by "range_" (like
| >>>> boost::range_const_iterator) just seems wrong to me when we
| >>>> have namespaces. Is there a good reason we're not using
| >>>> boost::range::const_iterator or boost::ranges::const_iterator?
| >>>
| >>> decision made in review or post-review. people like it that way.
| >>
| >> Count one more vote against, FWIW.
| >
| >
| > ok, will do. the question that I have is that will changing these
| > names have any effect except on me which has to do it?
| >
| > if we can provide more thourough naming guide-lines for future boost
| > libs, then let's do so.
| This affects me too. In the iostreams library I had metafunctions named
| and char_type which in the usual case simply extract member types of the
| name. In the interest of uniform naming I changed these to io_category and
| io_char, which sound a bit funny to me, esp. the latter.

well, you can't call it io::char :-)


Boost list run by bdawes at, gregod at, cpdaniel at, john at