From: Joel de Guzman (joel_at_[hidden])
Date: 2005-05-06 19:11:07
Eric Niebler wrote:
> Joel de Guzman wrote:
>> Dave Harris wrote:
>>> In-Reply-To: <989aceac050505060373e68a1_at_[hidden]>
>>> caleb.epstein_at_[hidden] (Caleb Epstein) wrote (abridged):
>>>>> What about the name? Shouldn't it be "BOOST_FOR_EACH"?
>>>> Why? Because of the distinct English words?
>>> Yes. And for consistency with other C++ macros, algorithms and keywords.
>>> I've argued at greater length in the other thread.
>> FWIW, I agree with Dave on this. We should not pretend it's a keyword.
>> It's not. Also, Peter noted that the proper spelling for the keyword
>> would be "for". So, if we try to follow that, it would have to be
>> spelled: "BOOST_FOR", which IMO is a lot better.
> I really don't care what it's called, but how are we to pick amongst
> BOOST_FOREACH, BOOST_FOR_EACH and BOOST_FOR? Straw poll?
> Also, I see:
> but I'm not aware of any official proposal to add this to the standard
> with this or any other syntax. And the motivation for prefering "for"
> over "foreach" or "for each" is to avoid adding a new keyword, not out
> of any sense of aesthetics. We are not so constrained. IMO, FOREACH
> reads better than FOR.
Well, you are the author, so you call the shots. No need for polls or
anything like that. Any name for our bicycle shed will be ok as
long as it is pink :-)
-- Joel de Guzman http://www.boost-consulting.com http://spirit.sf.net
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk