Boost logo

Boost :

From: Eric Niebler (eric_at_[hidden])
Date: 2005-05-06 13:33:59

Joel de Guzman wrote:
> Dave Harris wrote:
>> In-Reply-To: <989aceac050505060373e68a1_at_[hidden]>
>> caleb.epstein_at_[hidden] (Caleb Epstein) wrote (abridged):
>>>> What about the name? Shouldn't it be "BOOST_FOR_EACH"?
>>> Why? Because of the distinct English words?
>> Yes. And for consistency with other C++ macros, algorithms and keywords.
>> I've argued at greater length in the other thread.
> FWIW, I agree with Dave on this. We should not pretend it's a keyword.
> It's not. Also, Peter noted that the proper spelling for the keyword
> would be "for". So, if we try to follow that, it would have to be
> spelled: "BOOST_FOR", which IMO is a lot better.

I really don't care what it's called, but how are we to pick amongst

Also, I see:

but I'm not aware of any official proposal to add this to the standard
with this or any other syntax. And the motivation for prefering "for"
over "foreach" or "for each" is to avoid adding a new keyword, not out
of any sense of aesthetics. We are not so constrained. IMO, FOREACH
reads better than FOR.

Eric Niebler
Boost Consulting

Boost list run by bdawes at, gregod at, cpdaniel at, john at