From: Stefan Strasser (sstrasser_at_[hidden])
Date: 2005-05-09 09:39:49
you might be interested in this document from the new c++0x mailing:
for the naming discussion, proposed syntax is for(int i : vec)
(personally I don't care if it's called BOOST_FOREACH or BOOST_FOR)
I've questioned in the past if it is expected behaviour to do
"hoisting". the proposal does.
"4 Making a custom type work with the for loop" may also be
interesting to make the BOOST_FOREACH extension mechanism similar.
-- Stefan Strasser
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk