Boost logo

Boost :

From: Joe Gottman (jgottman_at_[hidden])
Date: 2005-05-09 19:19:23

"Stefan Strasser" <sstrasser_at_[hidden]> wrote in message
> you might be interested in this document from the new c++0x mailing:
> for the naming discussion, proposed syntax is for(int i : vec)
> (personally I don't care if it's called BOOST_FOREACH or BOOST_FOR)

   This proposal might be a good reason to rush BOOST_FOREACH into boost
version 1.33. If the standards committee is considering adding something
like BOOST_FOREACH, it would be good for them to have some data about how
easy and useful the average programmer finds this functionality.

Joe Gottman

Boost list run by bdawes at, gregod at, cpdaniel at, john at