Boost logo

Boost :

From: Doug Gregor (dgregor_at_[hidden])
Date: 2005-05-10 09:32:58

On May 9, 2005, at 7:19 PM, Joe Gottman wrote:
> "Stefan Strasser" <sstrasser_at_[hidden]> wrote in message
>> you might be interested in this document from the new c++0x mailing:
>> for the naming discussion, proposed syntax is for(int i : vec)
>> (personally I don't care if it's called BOOST_FOREACH or BOOST_FOR)
> This proposal might be a good reason to rush BOOST_FOREACH into
> boost
> version 1.33. If the standards committee is considering adding
> something
> like BOOST_FOREACH, it would be good for them to have some data about
> how
> easy and useful the average programmer finds this functionality.

It's too late to add anything into 1.33.


Boost list run by bdawes at, gregod at, cpdaniel at, john at