Boost logo

Boost :

From: David Abrahams (dave_at_[hidden])
Date: 2005-05-11 10:29:43

David Abrahams <dave_at_[hidden]> writes:

> Daniel Wallin <dalwan01_at_[hidden]> writes:
>> Sure. Maybe we should have two, so people who want to do metaprogramming
>> doesn't have to remove_reference<>?
>> binding<p, key, default>::type -> T | default
>> binding_result<p, key, default>::type -> T& | default
>> ?
> I don't understand why you'd want the one without the reference
> type... and -- I'm sure it's not what you want me to focus on -- but I
> don't like the name "binding_result" one bit.
> I'm inclined to vote "no" on this one. It isn't a flexibility that's
> known to be needed.

So far I've just renamed index_result to binding.

> Anyway, I'm inclined that we not try to do this by-value return
> thing. Your thoughts?

Still would like to hear them.

> Also:
> 1. for the lazy case we should probably use result_of<F()>::type on the
> compilers that support it?
> 2. We probably also need lazy_binding<p, k, f>::type, right?

Now done.

Dave Abrahams
Boost Consulting

Boost list run by bdawes at, gregod at, cpdaniel at, john at