Boost logo

Boost :

From: Paul A Bristow (pbristow_at_[hidden])
Date: 2005-05-15 12:48:25


| -----Original Message-----
| From: boost-bounces_at_[hidden]
| [mailto:boost-bounces_at_[hidden]] On Behalf Of Christoph Ludwig
| Sent: 07 May 2005 10:27
| To: boost_at_[hidden]
| Subject: Re: [boost] Math constants - updated.
| In the meantime, I had a look into the documentation. In
| rationale.html#which%20constants you list the constants
| provided. Unfortunately, this list is not current anymore. E.g.,
| double_constants.hpp defines twoPowThreeDivTwo which is not
| mentioned in
| rationale.html. cubeRootFour is called two_pow_two_thirds in the
| documentation.

Sorry I have not updated this much after the discussion during review.
I'll do some tidying up - thanks for noting this.

Briefly, there was no consensus on naming scheme, so I have
left it as something simple for the time being. I feel the
values are rather more important than the names.

| > This is way outside my knowledge zone - and I was unclear
| if and how many to
| > include.
| >
| > Do these have any practical use? Or are they only for Pure
| Mathematicians?
| I am not sure either. I have no use for the Riemann Zeta
| function right now,
| but it has a habit of popping up in areas where you did not
| expect it. So others might very well have use for these constants.

Well I can easily add them provided I can find accurate reference values.

| Regarding the question of how many constants to include: Can
| your source code
| easily be modified to generate other constants as well? Would
| it make sense to
| distribute it as well so users can easily generate other constants
| (say, sqrt(e), Riemann Zeta(n) for n > 3 etc.) if they need them?

No, not easily.

I have a trivial C++ program which uses Victor Shoup's NTL library,
(freely available) to calculate and write the files.

I could post the MS .lib file and the source, but I think
it would be easier for people to just ask me to generate a new set
of constants files (or a single file if a fancier MAcro-ized scheme
is felt more useful.

For example, sqrt(e) sounds like a useful addition and I will add it.


Paul A Bristow
Prizet Farmhouse, Kendal, Cumbria UK LA8 8AB
+44 1539 561830 +44 7714 330204
mailto: pbristow_at_[hidden]

Boost list run by bdawes at, gregod at, cpdaniel at, john at