Boost logo

Boost :

From: Rob Stewart (stewart_at_[hidden])
Date: 2005-07-10 12:29:19

From: "Jonathan Turkanis" <technews_at_[hidden]>
> I had another idea:
> device_stream, device_streambuf
> Unlike 'stream_facade' and 'streambuf_facade,' these are perfect descriptions of
> the components. They don't roll off the tongue very easily, though.

"device_stream" suggests a stream of devices rather than of
data. Besides, I don't really get the reference to "device."

That does lead me to suggest "data_stream" and "data_streambuf,"

Rob Stewart                           stewart_at_[hidden]
Software Engineer           
Susquehanna International Group, LLP  using std::disclaimer;

Boost list run by bdawes at, gregod at, cpdaniel at, john at