Boost logo

Boost :

From: Jonathan Turkanis (technews_at_[hidden])
Date: 2005-07-11 16:52:39

Rob Stewart wrote:
> From: "Jonathan Turkanis" <technews_at_[hidden]>
>> I had another idea:
>> device_stream, device_streambuf
>> Unlike 'stream_facade' and 'streambuf_facade,' these are perfect
>> descriptions of the components. They don't roll off the tongue very
>> easily, though.
> "device_stream" suggests a stream of devices rather than of
> data. Besides, I don't really get the reference to "device."
> That does lead me to suggest "data_stream" and "data_streambuf,"
> however.

Oddly, the library from which these components originally came was called

"data_stream" and "data_streambuf" have the same problem as "generic_stream" and
"generic_streambuf": the prefix "data_" doesn't add any information, since all
streams and stream buffers process data in one form or another. In fact, I think
they're slightly worse than "generic_stream" and "generic_streambuf," because
someone might think that "data" has a special meaning in this context, when in
fact it doesn't.

I think I've narrowed it down to "xxx_facade," "device_xxx," "devxxx" (suggested
by Gareth Sylvester-Bradley) and "xxxx" (note the extra 'x' ;-) ).

I'm going to try to get more people involved by soliciting votes. People seem to
like voting, for some reason.

Thanks for brainstorming with me.


Boost list run by bdawes at, gregod at, cpdaniel at, john at