Boost logo

Boost :

From: Rob Stewart (stewart_at_[hidden])
Date: 2005-07-26 15:12:32


From: Scott Schurr <scott_schurr_at_[hidden]>
>
> 2. Pavel Vozenilek thinks that the names binary_nibble and
> binary_int could be improved on. Pavel suggests
> the names 'nibble' and 'bits', noting that the term 'binary'
> has too many connotations in C++.
>
> At any rate, what do folks think would be good names for
> these two templates?

If not "binary" then what, "base2?"

IIUC, these templates produce numeric values from a binary
representation. Thus, the result is nothing more than a number
and its coming from binary digits is no longer important, so
"binary" doesn't need to be part of their name. Maybe putting
them in a "binary" namespace would help?

namespace binary
{
   template ...
   class number;

   template ...
   class nibble;
}

If you want to support signed and unsigned, then you'll have to
skirt around keywords with something like: signed_ and
unsigned_. (The same problem arises with your original
"binary_int:" it can't be binary::int.)

-- 
Rob Stewart                           stewart_at_[hidden]
Software Engineer                     http://www.sig.com
Susquehanna International Group, LLP  using std::disclaimer;

Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk