Boost logo

Boost :

From: Christopher Kohlhoff (chris_at_[hidden])
Date: 2005-08-18 17:53:18

--- Jeremy Maitin-Shepard <jbms_at_[hidden]> wrote:
> As a side note, perhaps the names read and write should be used
> rather than send and receive/recv if the library will at some point
> support I/O on non-sockets, such as pipes and fifos.

Yes, I agree that read and write are better, because of the
"portability" of the names to non-sockets that it gives. I've wanted to
make that change for some time, but the thing that has been preventing
me is what to call the datagram functions sendto and recvfrom, as
writeto and readfrom don't seem quite right. Any suggestions?


Boost list run by bdawes at, gregod at, cpdaniel at, john at