Boost logo

Boost :

From: Jeremy Maitin-Shepard (jbms_at_[hidden])
Date: 2005-08-18 18:38:54

Christopher Kohlhoff <chris_at_[hidden]> writes:

> --- Jeremy Maitin-Shepard <jbms_at_[hidden]> wrote:
>> As a side note, perhaps the names read and write should be used
>> rather than send and receive/recv if the library will at some point
>> support I/O on non-sockets, such as pipes and fifos.

> Yes, I agree that read and write are better, because of the
> "portability" of the names to non-sockets that it gives. I've wanted to
> make that change for some time, but the thing that has been preventing
> me is what to call the datagram functions sendto and recvfrom, as
> writeto and readfrom don't seem quite right. Any suggestions?

Well, one possibility is to just use the names `read' and `write'. If
necessary, these functions can be distinguished from the
connected-socket versions by the extra parameter. Alternatively, you
could use the names `unconnected_read' and `unconnected_write'.

Jeremy Maitin-Shepard

Boost list run by bdawes at, gregod at, cpdaniel at, john at