Boost logo

Boost :

From: Felipe Magno de Almeida (felipe.m.almeida_at_[hidden])
Date: 2005-09-06 05:14:45

On 9/4/05, Andrey Semashev <andysem_at_[hidden]> wrote:
> A few word of what I'm not sure of:
> - The naming of classes/functions/macroses. They look quite simple to me,
> but maybe someone has better proposals? Especially it concerns macroses
> (may be some prefixes?).

For what I know, the macros should be prefixed with BOOST.
And more important, shouldnt at all start or have __.

I didnt liked very much of the names Invoker and Functor, I dont think
they mean very much, mainly when used side by side... after all, isnt
Invoker a functor too?

Shouldnt the "CHandler" use operator() insted of on_exception? I think
it would make it more generic.

Best regards,

   Felipe Magno de Almeida
Developer from synergy and Computer Science student from State
University of Campinas(UNICAMP).
"There is no dark side of the moon really. Matter of fact it's all dark."

Boost list run by bdawes at, gregod at, cpdaniel at, john at