Boost logo

Boost :

From: Andrey Semashev (andysem_at_[hidden])
Date: 2005-09-06 13:26:51


Felipe Magno de Almeida wrote:
> On 9/4/05, Andrey Semashev <andysem_at_[hidden]> wrote:
>> A few word of what I'm not sure of:
>> - The naming of classes/functions/macroses. They look quite simple
>> to me, but maybe someone has better proposals? Especially it
>> concerns macroses (may be some prefixes?).
>
> For what I know, the macros should be prefixed with BOOST.
> And more important, shouldnt at all start or have __.

Yes, I've been told about this. These and some other cosmetic changes will
be applied in the next version.

> I didnt liked very much of the names Invoker and Functor, I dont think
> they mean very much, mainly when used side by side... after all, isnt
> Invoker a functor too?

They Invoker and Functor have different semantic. The first makes some pre-
and postarrangements (like catching exceptions, as with_catcher does), and
the second does the useful job. While the first one is a policy (wich can be
user-defined) and can be applied to invoke many different functors, the
second one is not even necessarilly written by you (it may be an API call,
for example). Getting rid of Invoker policy will eventually lead you to
hand-made analogues.

> Shouldnt the "CHandler" use operator() insted of on_exception? I think
> it would make it more generic.

The "CHandler" isn't necessarilly an object class. It might be an abstract
interface, for example. And making an interface of virtual operator()'s
isn't very convenient to my mind.


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk