Boost logo

Boost :

From: Andrey Semashev (andysem_at_[hidden])
Date: 2005-09-06 13:50:37

>> Shouldnt the "CHandler" use operator() insted of on_exception? I
>> think it would make it more generic.
> The "CHandler" isn't necessarilly an object class. It might be an
> abstract interface, for example. And making an interface of virtual
> operator()'s isn't very convenient to my mind.

But havinng thought of it for a while, you may be right here. At last, a
small functor-like adaptor may be made to deal with interfaces. I shall
change it in the next version.

Boost list run by bdawes at, gregod at, cpdaniel at, john at