Boost logo

Boost :

From: Andy Little (andy_at_[hidden])
Date: 2005-09-07 14:21:24

"Joel Eidsath" <jeidsath_at_[hidden]> wrote

> Okay, so this whole thing was just a naming issue?

It started as a misunderstanding on my part because of my preconceptions about
what a rational is, but it is just a naming issue. I believe that renaming would
result in greater clarity which surely cant be a bad thing. Apologies for making
so much noise.

>You have nothing to
> say about how I should code things?

Certainly not! Your ideas so far sound exciting. I will certainly be
interested to follow your progress.

> Sure, no problem. I was following
> Stroup's NTL who names his classes "ZZ" (Z stands for the integers in
> mathematics) and "RR" (R stands for the reals) respectively. All I'm
> working on right now is implementation. Suggest a name, and I'll note it.

How about APF standing for abitrary precision float?

Andy Little

Boost list run by bdawes at, gregod at, cpdaniel at, john at