From: Robert Ramey (ramey_at_[hidden])
Date: 2005-09-13 10:17:32
I looked at test_diamond and see that I used BOOST_ASSERT incorrectly and
will replace it with BOOST_CHECK.
I don't use BOOST_ASSERT as I could discern no difference between
BOOST_ASSERT and the standard assert(..) defined in <cassert>
I wonder if the macros from the Boost.Test should be renamed to include the
word test. EG BOOST_TEST_CHECK.
Stefan Seefeld wrote:
> I'm looking for references in boost library tests as to how to
> use BOOST_ASSERT correctly. I thus found the test_diamond tests
> in boost/serialization.
> It appears that the way BOOST_ASSERT is used there doesn't do
> anything in release mode, i.e. the expression isn't evaluated
> at all. (I modified the expression and the test still passed.)
> (As it happens, I was looking specifically for applications of
> http://www.boost.org/libs/utility/assert.html, as I want to use
> it in my own tests.)
> Unsubscribe & other changes:
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk