|
Boost : |
From: Thorsten Ottosen (nesotto_at_[hidden])
Date: 2005-09-15 11:46:10
Hi all,
Could we agree on a naming scheme/implementation scheme for the
customization-points?
I prefer
range_begin()
range_end()
range_size()
to
boost_range_begin()
boost_range_end()
boost_range_size()
and think these identifiers are unique enough, the small amout of global
costomization-points taken into consideration.
The consequence of this is that other libraries
should always call
boost::begin()
with qualification. This function must always fall back on
a function template which implements the default behavior.
The consequence for users is that they must
- provide hooks in their own namespace wich is then found via ADL.
- Users can specialize boost::begin, but not
boost::unspecified_namespace::range_begin.
- Global functions will not be found.
- derived to base-class conversion are not performed before ADL tries to
locate a function
-Thorsten
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk