Boost logo

Boost :

From: Jonathan Turkanis (technews_at_[hidden])
Date: 2005-09-15 17:15:14

Thorsten Ottosen wrote:
> Hi all,
> Could we agree on a naming scheme/implementation scheme for the
> customization-points?
> I prefer
> range_begin()
> range_end()
> range_size()
> to
> boost_range_begin()
> boost_range_end()
> boost_range_size()

Me too. Using boost_range_xxx seems like some sort of misplaced politeness. Do
we really think that someone else will use the names range_begin, etc.? If so,
we should claim them first. If not, what's the problem with our using them?

Also, it might be a good idea for someone to write Boost guidelines for
customization points, explaining the use of ADL, specialization of class
templates, broken-compiler workarounds, and the methods that don't work.

I'm might volunteer if no one else is eager, but it won't get done for a while.


Boost list run by bdawes at, gregod at, cpdaniel at, john at