Boost logo

Boost :

From: Jonathan Turkanis (technews_at_[hidden])
Date: 2005-09-15 17:19:51

Daniel Frey wrote:
> Thorsten Ottosen wrote:
>> Could we agree on a naming scheme/implementation scheme for the
>> customization-points?
>> I prefer
>> range_begin()
>> range_end()
>> range_size()
>> to
>> boost_range_begin()
>> boost_range_end()
>> boost_range_size()
>> and think these identifiers are unique enough, the small amout of
>> global costomization-points taken into consideration.
> I'd like to comment on a more general point than just the names:
> If we offer customizations points for a specific library, why should
> we use ADL at all?

You might want to read the recent threads "[serialization] Doc problems",
"[range] How to extend Boost.Range?" and the threads mentioned there.


Boost list run by bdawes at, gregod at, cpdaniel at, john at