Boost logo

Boost :

From: Andy Little (andy_at_[hidden])
Date: 2005-09-22 14:54:22

"Rob Stewart" <stewart_at_[hidden]> wrote in message
> From: "Andy Little" <andy_at_[hidden]>
>> "Thore Karlsen" <sid_at_[hidden]> wrote
>> How about :
>> guard.up();
>> guard.down();
> ...
> xyz.up();
> ...
> xyz.down();
> Out of context, and without a variable including (if not ending
> with) "guard," "up" and "down" don't fit well.

Is this not this variable always going to be called guard?(For example see
ScopeGuardTest.cpp in the distro) I assume theres only ever one per scope
Whatever I guess that these wont work either for the same reason.


Andy Little

Boost list run by bdawes at, gregod at, cpdaniel at, john at